Back to overview
Downtime

Storage Provider Outage

Jun 21 at 11:03pm UTC
Affected services
Content Storage Service

Resolved
Jun 22 at 01:14am UTC

The issue has been resolved. Sorry for the inconvenience.

Created
Jun 21 at 11:03pm UTC

Our upstream storage provider is currently experiencing a service outage. They are actively working on resolving the issue. However, we do not have an estimated time for when the situation will be resolved. Thank you for your patience and understanding.